Due to two (earlier one) of the AWS AZs being down in ME region and third AZ experiencing high error rates, LeadSquared is facing high error rates too in ME region.
March 3, 10:00 PM IST, We have successfully restored one more critical functionality, related to backend workflows. We are actively working with AWS to resolve the issue. More details can be referred at below link: https://health.aws.amazon.com/health/status
Posted Mar 04, 2026 - 00:17 IST
Identified
March 3, 1:37 PM IST, We have successfully restored select critical functionalities, including Login and read access to key entities. The team is actively working on restoring the remaining functionalities and continues to prioritize full service recovery at the earliest. Further updates will be shared as progress continues.
Posted Mar 03, 2026 - 20:32 IST
Investigating
Due to two of the AWS AZs being down in ME region and third AZ experiencing high error rates, LeadSquared is facing high error rates too in ME region. We are actively working with AWS to resolve the issue. More details can be referred at below link: https://health.aws.amazon.com/health/status
Posted Mar 02, 2026 - 13:08 IST
Monitoring
Following mitigation actions been taken in the ME region, all LSQ operations have returned to normal as of 03:30 AM IST, March 2. While we do not expect any more instability, we will continue to monitor the situation. We appreciate your patience and understanding during this period.