Performance degradation experienced in Mumbai Region

Incident Report for LeadSquared

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 15:55 IST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2025 - 11:50 IST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 07, 2025 - 10:56 IST

Investigating

We are currently experiencing slowness in Mumbai Region. The team is working on it and we will keep you posted. Apologies for the inconvenience.
Posted Apr 07, 2025 - 10:02 IST
This incident affected: Mumbai Data Center (in21) (API, Web Application, Mobile Application).