Issue with accessing LeadSquared application in Mumbai region
Incident Report for LeadSquared
Resolved
Few customers in Mumbai region faced issues accessing LeadSquared application between 11:30 AM IST and 12:12 PM IST. We have identified the issue and applied the patch.
The issue is now resolved and users are able to access the application. We apologize for the inconvenience caused.
Posted Mar 22, 2023 - 12:12 IST