Web application slowness in Singapore region
Incident Report for LeadSquared
Postmortem

The issue was caused by mass replacement of our application servers hosted on AWS EC2. The issue was automatically resolved in 10 minutes. We are looking at ways to avoid performance impact due to such mass replacements.

Posted Aug 03, 2019 - 10:18 IST

Resolved
Some of the Singapore users (run.leadsquared.com) may experience web application slowness. We are investigating the cause and will address it ASAP.
Posted Aug 02, 2019 - 12:15 IST