Degraded performance is observed in the US region for certain features due to an ongoing AWS OpenSearch Service issue in the us-east-1 region.

Incident Report for LeadSquared

Resolved

All LSQ operations have returned to normal as of 1:57 AM IST, April 3. Customers requiring assistance related to this event are encouraged to contact our Support team. We appreciate your patience and understanding while we have worked to restore services.
Posted Apr 03, 2026 - 03:25 IST

Monitoring

We have restored functionality and are actively monitoring. Customers requiring assistance related to this event are encouraged to contact our Support team. We appreciate your patience and understanding while we have worked to restore services.
Posted Apr 03, 2026 - 01:27 IST

Update

We have restored functionality for a subset of customers and are actively working to restore service for the remaining users. We appreciate your patience as we continue to resolve this issue.
Posted Apr 03, 2026 - 00:17 IST

Identified

We are observing degraded performance in some functionalities of the LeadSquared application in the US region due to an ongoing AWS OpenSearch Service issue in the us-east-1 region. We are actively working with AWS to restore performance.
Posted Apr 02, 2026 - 20:16 IST
This incident affected: US Data Center (us11) (API, Web Application, Mobile Application).